Ignition problems

This section is for technical Q & A
Please try the search function before starting a new thread.
Forum rules
Many subjects will have been discussed before. Please try the search function before starting a new thread.
Check in the Know Your 2 as the information you need may already be there.
Post Reply

Topic author
andyh1964
Posts: 17
Joined: 14/04/18 15:56
Gender: Male
Years of MR2 Ownership: 0
MR2's Owned: 0
Real Name: Andy Horn
Location: Guisborough
Contact:

Ignition problems

Post by andyh1964 » 01/12/18 11:10

Hi all.
We seem to have a problem with the ignition, we changed the engine oil as it looked a bit gloopy, all good on that front.
Once we built up the oil pressure we fired the engine up and all was good again.
However after letting it cool down to check oil level, we started it again and after a couple of minutes it will simply stopped and wouldn't start again.
We took a spark plug out and tested for a spark, result no spark.
After an internet search it's looking like the problem could be the coil igniter, which are difficult to find.
I have not had chance to run a diagnostic test to prove it though.
Has anyone experienced this particular issue and if there is way to repair the igniter or replace it with one of a different car igniter.
Occasionally in the past it has randomly cut out, but usually it would start again after a couple of attempts.
Thanks in advance Andy



User avatar

jimi
Administrator
Administrator
Posts: 3711
Joined: 17/05/04 1:00
Gender: Male
Years of MR2 Ownership: 14
MR2's Owned: 1
Location: Glenrothes: The Kingdom of Fife
Been thanked: 3 times
Contact:

Re: Ignition problems

Post by jimi » 01/12/18 14:28

Black is not a colour ! .... Its the absence of colour
Image


Topic author
andyh1964
Posts: 17
Joined: 14/04/18 15:56
Gender: Male
Years of MR2 Ownership: 0
MR2's Owned: 0
Real Name: Andy Horn
Location: Guisborough
Contact:

Re: Ignition problems

Post by andyh1964 » 01/12/18 14:53

No not yet, as soon as it stops raining I'll check the error codes.
Thanks


Topic author
andyh1964
Posts: 17
Joined: 14/04/18 15:56
Gender: Male
Years of MR2 Ownership: 0
MR2's Owned: 0
Real Name: Andy Horn
Location: Guisborough
Contact:

Re: Ignition problems

Post by andyh1964 » 02/12/18 19:42

Having checked the error codes it appears we have a none working coil igniter, however it starts.
Any ideas?
Cheers

User avatar

jimi
Administrator
Administrator
Posts: 3711
Joined: 17/05/04 1:00
Gender: Male
Years of MR2 Ownership: 14
MR2's Owned: 1
Location: Glenrothes: The Kingdom of Fife
Been thanked: 3 times
Contact:

Re: Ignition problems

Post by jimi » 23/12/18 15:46

What code did you get ?
Black is not a colour ! .... Its the absence of colour
Image


Topic author
andyh1964
Posts: 17
Joined: 14/04/18 15:56
Gender: Male
Years of MR2 Ownership: 0
MR2's Owned: 0
Real Name: Andy Horn
Location: Guisborough
Contact:

Re: Ignition problems

Post by andyh1964 » 24/12/18 9:46

I got 3 flashing lights which so far as I know indicates a problem with the igniter, ignition circuit or the ECU according to this https://www.mr2oc.co.uk/know-your-2.htm ... kbartid=61

After further investigation, since the engine failed to start, the distributor and rotor arm have seen better days.
Once I have replaced these parts I'll report back with my findings.
Merry Christmas🎁🎄🎅

Post Reply

Return to “MK1”