New Owner Battery Discharge & Engine Fan Light

This section is for technical Q & A
Please try the search function before starting a new thread.
Forum rules
Many subjects will have been discussed before. Please try the search function before starting a new thread.
Check in the Know Your 2 as the information you need may already be there.
Post Reply

Topic author
Ras
Full Member
Full Member
Posts: 2
Joined: 16/09/19 14:37

New Owner Battery Discharge & Engine Fan Light

Post by Ras » 16/09/19 16:28

Hey All,

New member and new owner here. Loving my 2 and glad to be on board!
Excuse me if this has been covered before, I have had searched deeply across multiple threads and cant find anything similar to my problem, as it always seems to be the lights are perminatley on.

I'm new to mechanics but eager to learn, so if its an obvious one fix do let me know.

Got a 1985 Mr2 mk1.
Engine is fine when idling, no lights. Rev it = fine no lights.
At operating temp, and rev it. Fine no lights.

Only when I actually drive it, will the engine fan light and battery discharge light come on.
Sometimes it is seemingly random. Other times it is when I de-clutch and bring down to idling.

Engine temperature never goes above operating.

Any advice would be apprecieted and thanks for taking the time!



User avatar

MR2DI4
Posts: 1141
Joined: 20/04/11 23:18
Gender: Male
Years of MR2 Ownership: 21
MR2's Owned: 1
Real Name: Carl
Location: Auckland >>> New Zealand

Re: New Owner Battery Discharge & Engine Fan Light

Post by MR2DI4 » 16/09/19 20:19

Sounds a bit similar to the MK2, it could be an alternator problem developing.


Rich135
Posts: 3
Joined: 05/06/19 16:13

Re: New Owner Battery Discharge & Engine Fan Light

Post by Rich135 » 17/09/19 14:53

I had a similar scenario a month or two ago, and it was just after I had a flat battery and had jump started the car.

Give the battery a really good charge overnight and make sure the terminals are fully tight on the top. Also check any "earths" from the engine, in case they are loose. Sorry I don't know exactly where the earth straps are, but hopefully the first two steps will fix it!

Good luck,

Rich


Topic author
Ras
Full Member
Full Member
Posts: 2
Joined: 16/09/19 14:37

Re: New Owner Battery Discharge & Engine Fan Light

Post by Ras » 19/09/19 5:06

Ok that's a good thought.

Turns out my main negative ground and the ground very near the engine fan are rusty AF.
The engine fan one was actually nearly half eaten away.

Checked all the others, that I could find. And they are shiny and tight.

So have ordered some new brass bolts and washers and will update!

Let's hope it's not the alternator 😬

Post Reply

Return to “MK1”