One headlight won't pop up (Rev 2 Turbo)

This section is for technical Q & A
Please try the search function before starting a new thread.
Forum rules
Many subjects will have been discussed before. Please try the search function before starting a new thread.
Check in the Know Your 2 as the information you need may already be there.
Important ! - Please make your topic title as descriptive as possible . titles with just "help" generally dont get as many answers as a title that points to the problem
Post Reply

Topic author
DaveWS
Posts in topic: 3
Posts: 7
Joined: 05/05/16 19:53

One headlight won't pop up (Rev 2 Turbo)

Post by DaveWS » 13/07/18 12:14

Hi all, one of my headlights has stopped popping up. For a while it would intermittently work, but now it no longer moves at all (drivers side). I disconnected both motor units, and I've tested the drivers side motor on the nearside, and the motor unit works fine, so it's not that. I've tested the connectors to ground and that's fine, but I don't really know what I'm doing beyond that (I have a multi-meter). Any ideas? Thanks



User avatar

abovetherim
Full Member
Full Member
Posts in topic: 4
Posts: 688
Joined: 29/01/11 18:53
Gender: Male
Years of MR2 Ownership: 7
MR2's Owned: 1
Real Name: Jan Olsson
Location: Leicester

Re: One headlight won't pop up (Rev 2 Turbo)

Post by abovetherim » 13/07/18 14:51

Maybe worth checking the connector at the blue controller box in the frunk. If they ok open it up and check the circuit board. Not sure if there will be board mounted relays in there but I know there are capacitors to drive the up/down function. In the ky2 section or somewhere on this site is a how to on replacing these capacitors to reduce the time lag. It was written by trevsmr2 if that helps the search.
1991 rev 1 T Bar n/a 3sge import. A work in progress!!!


Topic author
DaveWS
Posts in topic: 3
Posts: 7
Joined: 05/05/16 19:53

Re: One headlight won't pop up (Rev 2 Turbo)

Post by DaveWS » 13/07/18 17:01

Thanks for the tip. I've isolated the problem to a broken connection between pin 5 of the blue box connector and pin 2 of the motor connector, the green wire. I'd guess it's extremely unlikely the wire itself would fail, so I'm assuming it's the contact in one of the two connectors. I guess the only option is to strip away a bit of wire insulation to verify which one.

User avatar

abovetherim
Full Member
Full Member
Posts in topic: 4
Posts: 688
Joined: 29/01/11 18:53
Gender: Male
Years of MR2 Ownership: 7
MR2's Owned: 1
Real Name: Jan Olsson
Location: Leicester

Re: One headlight won't pop up (Rev 2 Turbo)

Post by abovetherim » 13/07/18 20:23

So you have put a meter across both ends of this green wire and got no continuity?

Wires can get chafed in all parts of the loom esp when they are this old and fixing points for the looms may have been messed with.

I got a Saab and an absolute wire breaking at a point on the chassis where it is zip tied is a common problem.
1991 rev 1 T Bar n/a 3sge import. A work in progress!!!

User avatar

abovetherim
Full Member
Full Member
Posts in topic: 4
Posts: 688
Joined: 29/01/11 18:53
Gender: Male
Years of MR2 Ownership: 7
MR2's Owned: 1
Real Name: Jan Olsson
Location: Leicester

Re: One headlight won't pop up (Rev 2 Turbo)

Post by abovetherim » 13/07/18 20:24

Oh and you can use a couple of drawing pins as spikes to pierce the wire sheath to meter it.
1991 rev 1 T Bar n/a 3sge import. A work in progress!!!


Topic author
DaveWS
Posts in topic: 3
Posts: 7
Joined: 05/05/16 19:53

Re: One headlight won't pop up (Rev 2 Turbo)

Post by DaveWS » 13/07/18 22:16

Thanks for that tip! Just verified that it's definitely the connector that's gone bad, I guess moisture has found its way inside. There's continuity between the relay box and the wire immediately behind the connector, but nothing to the contact in the connector itself.

User avatar

abovetherim
Full Member
Full Member
Posts in topic: 4
Posts: 688
Joined: 29/01/11 18:53
Gender: Male
Years of MR2 Ownership: 7
MR2's Owned: 1
Real Name: Jan Olsson
Location: Leicester

Re: One headlight won't pop up (Rev 2 Turbo)

Post by abovetherim » 14/07/18 0:34

Easy fix then. Drill hole in casing and solder jumper wire to the board where the connector for green wire is then solder other end to green wire. You could put a bullet connector in the jumper line if you think you may need to disconnect in the future.
1991 rev 1 T Bar n/a 3sge import. A work in progress!!!

Post Reply

Return to “MK2”