MR2 MK2 NA Won't Start (Has Fuel, Weak Spark?)

This section is for technical Q & A
Please try the search function before starting a new thread.
Forum rules
Many subjects will have been discussed before. Please try the search function before starting a new thread.
Check in the Know Your 2 as the information you need may already be there.
Important ! - Please make your topic title as descriptive as possible . titles with just "help" generally dont get as many answers as a title that points to the problem
Post Reply

Topic author
MGBENG
Posts: 5
Joined: 13/10/15 20:40
Years of MR2 Ownership: 0
MR2's Owned: 1
Real Name: Patrick
Gender: Male
Location: Norwich

MR2 MK2 NA Won't Start (Has Fuel, Weak Spark?)

Post by MGBENG »

Hi everyone,

My rev 5 NA won't start. It is a 1999 UK car with about 105K miles on the clock. Car is essentially stock, but has an aftermarket air filter and exhaust. I last drove it two days ago. It is currently very damp outside and below freezing. Over the last three weeks or so the car has picked up a bit of a missfire when it's cold. It also used to start almost instantly (~1 second) but has recently been taking a little longer (~2 seconds).

It cranks really quick so don't think it is battery. It has almost a full tank of fuel.

Have removed a spark plug and grounded it to the motor - spark is there but weak (orange, can't hear a noise either) and seems intermittent. Tried again, this time attaching a jumper cable to end of plug and grounding that to one of the nuts on top of the right strut - same issue. Plug is wet with fuel. Car smells faintly of fuel after cranking for ~5 seconds.

I loosened the nut on the engine side of the fuel filter and fuel comes "censored" out when the car is cranked.

So, I guess that suggests it is either the weak spark that is the issue, or perhaps the timing belt has slipped?

Should I be looking at getting a new coil and igniter? Any other suggestions from anyone? What's the easiest way to see if the belt has slipped.

Thanks for your time,

Patrick


User avatar

peteV6R5
Posts: 2658
Joined: 13/08/07 13:06
Years of MR2 Ownership: 12
MR2's Owned: 2
Real Name: Pete
Gender: Male
Location: Stratford upon Avon
Has thanked: 2 times
Been thanked: 9 times

Re: MR2 MK2 NA Won't Start (Has Fuel, Weak Spark?)

Post by peteV6R5 »

See if you get good spark off the king lead from the igniter.
If yes it rules out igniter issue (which I think is a possibility - have tendency to crack and produce weak spark when wet).
If thats OK then check Dizzy and leads (wipe leads down with WD soaked rag to clean crap off, it also very temporary seals any cracks had helps give better spark (not a fix very temp to help loacte). if that fixes it then I would suggest new Dizzy cap, rotor and leads.
the one thing I had was faulty fuel pump, fuel was P+++ing out of pipe it appeared but no where near the right pressure as it turned out (32-38psi), new fuel pump later all good again.
your belt hasn't slipped I wager if it was running when dry its more likely coil / igniter / dizzy or leads IMO
Image
Highland Drive 13/14/15/17/18/19
JAE 07/09/10/11/12/13/14/15/16/17
Japfest 09/11/12/13/16/19
Wales runs 14/15/16/17/18

Topic author
MGBENG
Posts: 5
Joined: 13/10/15 20:40
Years of MR2 Ownership: 0
MR2's Owned: 1
Real Name: Patrick
Gender: Male
Location: Norwich

Re: MR2 MK2 NA Won't Start (Has Fuel, Weak Spark?)

Post by MGBENG »

Hi Pete, thanks for the info that's much appreciated and a good troubleshooting sheet.

I changed the coil (which was cracked) and all is now good.

What an absolutely pain to change though! Had to drill the heads off of the four screws holding the coil on, then tried to remove the stumps with mole grips and they all broke... had to drill all of them out and then 3D printed a couple of nut plates and replaced the screws with stainless M4 capheads. 30 minute job turned into 3 hours!
User avatar

jimi
Administrator
Administrator
Posts: 4400
Joined: 17/05/04 1:00
Answers: 1
Years of MR2 Ownership: 18
MR2's Owned: 1
Gender: Male
Location: Glenrothes: The Kingdom of Fife
Has thanked: 9 times
Been thanked: 42 times
Contact:

Re: MR2 MK2 NA Won't Start (Has Fuel, Weak Spark?)

Post by jimi »

Good that got it sorted, lucky you had the facilities to 3D print. :th:
Black is not a colour ! .... Its the absence of colour
Image
User avatar

peteV6R5
Posts: 2658
Joined: 13/08/07 13:06
Years of MR2 Ownership: 12
MR2's Owned: 2
Real Name: Pete
Gender: Male
Location: Stratford upon Avon
Has thanked: 2 times
Been thanked: 9 times

Re: MR2 MK2 NA Won't Start (Has Fuel, Weak Spark?)

Post by peteV6R5 »

nice to hear you got it fixed
Image
Highland Drive 13/14/15/17/18/19
JAE 07/09/10/11/12/13/14/15/16/17
Japfest 09/11/12/13/16/19
Wales runs 14/15/16/17/18
Post Reply

Return to “MK2”