Mk3 Steering Pump Not working

This section is for technical Q & A
Please try the search function before starting a new thread.
Forum rules
Many subjects will have been discussed before. Please try the search function before starting a new thread.
Check in the Know Your 2 as the information you need may already be there.
Post Reply

Topic author
stevehaylingisland
Posts: 7
Joined: 19/11/19 12:45

Mk3 Steering Pump Not working

Post by stevehaylingisland » 19/11/19 13:11

Hi, I have just bought a Mk3 with a few issues to fix. Most of the bits that need doing are no problem but the power steering pump was not working so I have replaced with another second hand unit which also does not run at all. I have checked the related 3 fuses and power relay and they seem fine. Can any one please point me to any depth articles on the EHPS. We plugged in a diagnostic tool also which showed no evidence of any area concerned with the power steering? There are no warning lights saying fault also. Any direction would be appreciated.



User avatar

peteV6R5
Full Member
Full Member
Posts: 2702
Joined: 13/08/07 13:06
Gender: Male
Years of MR2 Ownership: 12
MR2's Owned: 2
Real Name: Pete
Location: Stratford upon Avon
Has thanked: 1 time
Been thanked: 3 times

Re: Mk3 Steering Pump Not working

Post by peteV6R5 » 19/11/19 14:17

IDK the answer but quick google

https://www.mr2oc.co.uk/forum/41/166474.html
http://www.mr2.com/forums/threads/58577 ... ng-failure!
there are sub threads in each of the bottom 2 links
Image
Highland Drive 13/14/15/17/18/19
JAE 07/09/10/11/12/13/14/15/16/17
Japfest 09/11/12/13/16/19
Wales runs 14/15/16/17/18


SteveandDebra1
Full Member
Full Member
Posts: 38
Joined: 04/12/18 16:23
Gender: Male
Years of MR2 Ownership: 11
MR2's Owned: 2
Real Name: Steve
Location: Ashford Kent

Re: Mk3 Steering Pump Not working

Post by SteveandDebra1 » 20/11/19 15:42

Hi I had the same problem with my 1992 MR2. I read on a fororum that if you turn the ignition on and off for 30 times ( yes 30 times this cures the problem). So thought nothing to lose give it a go. Hey power steering works fine and not had a problem since.
Regards


SteveandDebra1
Full Member
Full Member
Posts: 38
Joined: 04/12/18 16:23
Gender: Male
Years of MR2 Ownership: 11
MR2's Owned: 2
Real Name: Steve
Location: Ashford Kent

Re: Mk3 Steering Pump Not working

Post by SteveandDebra1 » 20/11/19 17:12

Yes had the same problem and the above post cured it.
Regards


Topic author
stevehaylingisland
Posts: 7
Joined: 19/11/19 12:45

Re: Mk3 Steering Pump Not working

Post by stevehaylingisland » 20/11/19 22:09

I don't think it is that simple becouse the power relay is working and clicking in. I will do it again 30 times. Nothing lost. Thank you for the advice.


Topic author
stevehaylingisland
Posts: 7
Joined: 19/11/19 12:45

Re: Mk3 Steering Pump Not working

Post by stevehaylingisland » 23/11/19 22:09

I guess I will have to dig in and try to work it out. Does anyone know if there are decent electrical schematics that might cover this.

User avatar

ayresyboy
Regional Rep
Regional Rep
Posts: 561
Joined: 22/04/08 8:31
Gender: Male
Years of MR2 Ownership: 11
MR2's Owned: 8
Real Name: Andy Ayres
Location: East London
Has thanked: 2 times
Been thanked: 2 times

Re: Mk3 Steering Pump Not working

Post by ayresyboy » 23/11/19 23:27

Give it a few taps with a spanner
Mk1 Supercharger Blue...SORN
Mk2 TRD2000GT #0001 Red...GOING TURBO
Mk2 1MZ V6 Auto Black...DAILY
Mk3 2GR V6 Blue...SORN


Topic author
stevehaylingisland
Posts: 7
Joined: 19/11/19 12:45

Re: Mk3 Steering Pump Not working

Post by stevehaylingisland » 24/11/19 11:19

Yes thanks lol


Topic author
stevehaylingisland
Posts: 7
Joined: 19/11/19 12:45

Re: Mk3 Steering Pump Not working

Post by stevehaylingisland » 24/11/19 15:56

I have been trying to research on the web and found an article where a guy is using the ehps pump on a different vehicle. From his diagram I can get the pump to run on the bench. The main tip is that he sends a trigger 12v to pin 4 of the pumps connector P8. Can any one give any more pointers. Another question is to ask if there is a P/S fail on the year 2000 roadster. Also has any one the code reader that can see the power steering.
I have put the power steering link about Plug 8 pin 4 below.

https://www.k20a.org/threads/electric-h ... 001.58599/


Topic author
stevehaylingisland
Posts: 7
Joined: 19/11/19 12:45

Re: Mk3 Steering Pump Not working

Post by stevehaylingisland » 25/11/19 17:32

I have worked a bit further. The feed to pin 4 of connector 8 comes from the combination meter in the speedo pod this lighting up the engine management warning symbol. When I look in the clock someone has put black tape over it to stop it showing the warning. So the engine warning symbol is on all the time and yet the code reader is picking up no codes. Another thing that I have noticed is a small red led flashing in the middle of the dash above the gear stick. I assume this means something to do with the alarm. Any pointers appreciated.


Topic author
stevehaylingisland
Posts: 7
Joined: 19/11/19 12:45

Re: Mk3 Steering Pump Not working

Post by stevehaylingisland » 01/12/19 16:01

Solved. I have solved this not by by brilliance but by buying another complete car and swapping the complete Key set ecu abs ecu body control ecu instrument cluster key transponder all in one go so as not to upset the security system, Did this and the P/S light lit up. This was a surprise as my other cluster did not have a P/S warning light! Well it did but someone had painted it out with black paint. Cutting a long story short this meant that the fault was in the hardware. The fault was an almost corroded through terminal that the heavy white wire has to join to the underside of the 50amp fuse. This is in fuse board in the frunk and supplies the pump.


J88TEO
Full Member
Full Member
Posts: 4
Joined: 27/08/19 14:42

Re: Mk3 Steering Pump Not working

Post by J88TEO » 02/12/19 13:17

Excellent.
Have about the same problem with my 2004 sable grey MR2 - intermittent problem...

Post Reply

Return to “MK3”