engine stalls after 4 seconds

This section is for technical Q & A
Please try the search function before starting a new thread.
Forum rules
Many subjects will have been discussed before. Please try the search function before starting a new thread.
Check in the Know Your 2 as the information you need may already be there.

PaulWoods
Posts in topic: 25
Posts: 891
Joined: 28/05/03 1:00
Gender: Male
Years of MR2 Ownership: 19
MR2's Owned: 28
Location: Durham
Contact:

Re: engine stalls after 4 seconds

Post by PaulWoods » 14/09/18 12:02

Yeah it wouldn't surprise me if it had a 1b 7 rib block/42mm bottom end, these crossover cars can be a nightmare to figure out what Toyota used on them, even the EPC doesn't work properly for them.


I have a 17030 ECU which should run that engine, once you have confirmed there is no noid light signal at the injectors I will send you this ECU, if that doesn't work I have no further remote tests I can advise and then you're going to need to trailer it to me or another Mr2 specialist.




Topic author
jim2167
Full Member
Full Member
Posts in topic: 33
Posts: 33
Joined: 16/08/18 20:57

Re: engine stalls after 4 seconds

Post by jim2167 » 14/09/18 16:07

No signal on the noid light, so chances are it is the ecu


PaulWoods
Posts in topic: 25
Posts: 891
Joined: 28/05/03 1:00
Gender: Male
Years of MR2 Ownership: 19
MR2's Owned: 28
Location: Durham
Contact:

Re: engine stalls after 4 seconds

Post by PaulWoods » 14/09/18 16:50

Ok, drop me an email paul@woodsport.org with your address and I will send this one for you to try.


PaulWoods
Posts in topic: 25
Posts: 891
Joined: 28/05/03 1:00
Gender: Male
Years of MR2 Ownership: 19
MR2's Owned: 28
Location: Durham
Contact:

Re: engine stalls after 4 seconds

Post by PaulWoods » 17/09/18 7:32

ECU being sent out today, i will cover the postage costs, if it works a small donation to this club would be appreciated, thanks Paul.


Topic author
jim2167
Full Member
Full Member
Posts in topic: 33
Posts: 33
Joined: 16/08/18 20:57

Re: engine stalls after 4 seconds

Post by jim2167 » 17/09/18 15:51

No problems. Thanks


Topic author
jim2167
Full Member
Full Member
Posts in topic: 33
Posts: 33
Joined: 16/08/18 20:57

Re: engine stalls after 4 seconds

Post by jim2167 » 19/09/18 14:32

ecu arrived today but still the car does not run. It will now try to fire but now thinking the injectors may still be partly blocked
I have a noid light at the injectors now so that is an improvement, I've checked the timing and the fuel supply to the injectors which is all ok.


PaulWoods
Posts in topic: 25
Posts: 891
Joined: 28/05/03 1:00
Gender: Male
Years of MR2 Ownership: 19
MR2's Owned: 28
Location: Durham
Contact:

Re: engine stalls after 4 seconds

Post by PaulWoods » 20/09/18 7:01

So if it now gets a noid light flash it means your old ECU was faulty, you say you're getting full fuel pressure to the injectors so it can only be gummed up injectors now, i would advise removing them and having them ultrasonically cleaned.

Glad my ECU helped.


Topic author
jim2167
Full Member
Full Member
Posts in topic: 33
Posts: 33
Joined: 16/08/18 20:57

Re: engine stalls after 4 seconds

Post by jim2167 » 20/09/18 23:29

The injectors are being cleaned and will be ready tomorrow. They might of worked when connected directly to the battery because having a full 12 volt supply but not when the engine should just be on tick over as i understand the supply voltage is less and my faulty ecu would also explain why it was running on only 1 or 2 cylinders.


PaulWoods
Posts in topic: 25
Posts: 891
Joined: 28/05/03 1:00
Gender: Male
Years of MR2 Ownership: 19
MR2's Owned: 28
Location: Durham
Contact:

Re: engine stalls after 4 seconds

Post by PaulWoods » 21/09/18 6:59

Quite possibly, cleaning the injectors will certainly rule them out anyway.

User avatar

Gazza_DJ
Regional Rep
Regional Rep
Posts in topic: 1
Posts: 2678
Joined: 29/11/10 19:50
Years of MR2 Ownership: 0
MR2's Owned: 1
Location: Essex

Re: engine stalls after 4 seconds

Post by Gazza_DJ » 21/09/18 9:35

^Someone buy this man a beer :clapping:
Rev5 Sonic Shadow
Image


Topic author
jim2167
Full Member
Full Member
Posts in topic: 33
Posts: 33
Joined: 16/08/18 20:57

Re: engine stalls after 4 seconds

Post by jim2167 » 21/09/18 18:05

WE HAVE A RUNNER of sorts, Injectors back but 1 has an electrical short and have been told it is u.s.
So refitted all 4 but didn't connect the bad injector (it might be what killed my ecu in the first place) and after a little bit of encouragement (easy start) she ran, only on 3 cylinders but I know why.

Thank you all for you wonderful help, I hope to thank you in person at some meeting or runs next year.
As i said at the beginning or the post this car was lasted MOT in 2001, so far I have only found 4 holes all weldable which is not bad for a £200 barn find.

Thanks again from a now happy MR2 owner

User avatar

jimi
Administrator
Administrator
Posts in topic: 14
Posts: 3429
Joined: 17/05/04 1:00
Gender: Male
Years of MR2 Ownership: 14
MR2's Owned: 1
Location: Glenrothes: The Kingdom of Fife
Contact:

Re: engine stalls after 4 seconds

Post by jimi » 21/09/18 19:53

Excellent, let us know how you get once once you have the replacement injector fitted.
Black is not a colour ! .... Its the absence of colour
Image

User avatar

benckj
Posts in topic: 3
Posts: 156
Joined: 05/04/06 1:00
Gender: Male
Years of MR2 Ownership: 5
Location: Alexandra, New Zealand

Re: engine stalls after 4 seconds

Post by benckj » 21/09/18 19:56

Good job as it’s been a long dramatic affair with this problem. Glad you had the support to work it out.

User avatar

angpozzuto
Full Member
Full Member
Posts in topic: 1
Posts: 366
Joined: 25/04/13 21:25
Gender: Male
Years of MR2 Ownership: 4
MR2's Owned: 3
Real Name: angelo
Location: cheshunt

Re: engine stalls after 4 seconds

Post by angpozzuto » 21/09/18 22:51

Good to see you've got to the bottom of your issues, time to get moted and out on the road
Supercharged v6 mk1 build thread
https://www.mr2oc.co.uk/forums/125/166558.html

Post Reply

Return to “MK1”