Electric Aerial Makes Noise but Won’t Move

This section is for technical Q & A only - any other threads will be deleted/moved. Please try the search function before starting a new thread.
Post Reply

Topic author
NedPowell
Full Member
Full Member
Posts: 5
Joined: 14/07/22 11:14
Current Model: MK2
Years of MR2 Ownership: 1
MR2's Owned: 1

Electric Aerial Makes Noise but Won’t Move

Post by NedPowell »

Hey guys,

Looking for some help with the electric aerial on my rev 3. A while back I replaced the mast as the one fitted when I bought the car was bent and wouldn’t retract all the way. Following the KY2 repair instructions, I cleaned all the old grease out and replaced with fresh stuff. However, I think this is where I made a grave mistake.

When cleaning out the old stuff, I took out the big white gear that the nylon cord wraps around and split the two pieces apart to see if this needed grease. Inside was a complete mess of what looked like a badly corroded spring type piece, which crumbled apart when pressed. I’m assuming this spring was making the gear act as some sort of clutch mechanism to stop the mast when it reaches the end of its travel, and breaking this has stopped this mechanism from engaging. Now, when I turn the car on, the motor makes noise but the mast doesn’t move at all.

Does anybody have any more knowledge of these electric aerials, and what I might be able to do to fix this? I’ve searched the forums but to no avail… I’ve found it’s very hard to come by a replacement aerial unit, and I would really like to get it functioning again as I think it’s a pretty cool mechanism. If anyone can help me repair my foolish mistake I’d be very grateful.

Thanks in advance,
Ned


User avatar

jimi
Administrator
Administrator
Posts: 5121
Joined: 17/05/04 1:00
Years of MR2 Ownership: 18
MR2's Owned: 1
Gender: Male
Location: Glenrothes: The Kingdom of Fife
Has thanked: 44 times
Been thanked: 114 times
Contact:

Re: Electric Aerial Makes Noise but Won’t Move

Post by jimi »

Black is not a colour ! .... Its the absence of colour
Image

Topic author
NedPowell
Full Member
Full Member
Posts: 5
Joined: 14/07/22 11:14
Current Model: MK2
Years of MR2 Ownership: 1
MR2's Owned: 1

Re: Electric Aerial Makes Noise but Won’t Move

Post by NedPowell »

Hi Jimi,

Thanks for getting back to me. I have indeed, as mentioned in my post I used that KY2 article as a guide for rebuilding/repairing my aerial, however my issue is specifically about the clutch gear inside the aerial which is not covered in that article. I’m looking for advice on obtaining a new clutch gear or repairing my broken one if anybody has that knowledge.
1996 MK2 Rev 3 T-Top N/A - 202 Astral Black
User avatar

jimi
Administrator
Administrator
Posts: 5121
Joined: 17/05/04 1:00
Years of MR2 Ownership: 18
MR2's Owned: 1
Gender: Male
Location: Glenrothes: The Kingdom of Fife
Has thanked: 44 times
Been thanked: 114 times
Contact:

Re: Electric Aerial Makes Noise but Won’t Move

Post by jimi »

Sorry skimmed over the KY2 part :blush:
AFAIK none of the internal parts were available (apart from the extending drive) new, never seen a part number for the drive gears or motor.
I suspect your only hope would be to take a chance an getting a second hand (even a non working ) antenna and using the parts to make one good working one.
Or possibly LINKY
Black is not a colour ! .... Its the absence of colour
Image
User avatar

jeff
Administrator
Administrator
Posts: 1621
Joined: 28/04/03 1:00
Current Model: MK2
Years of MR2 Ownership: 20
MR2's Owned: 1
Real Name: Jeff
Gender: Male
Location: Nottingham
Has thanked: 34 times
Been thanked: 19 times
Contact:

Re: Electric Aerial Makes Noise but Won’t Move

Post by jeff »

for £50 i would go for that option, you could spend time and effort trying to fix your original mast and still be no better off
Not Plan B again!! Why don't we just go with plan B in the first place?
It’s more important to lose a minute in life than your life in a minute
User avatar

jimi
Administrator
Administrator
Posts: 5121
Joined: 17/05/04 1:00
Years of MR2 Ownership: 18
MR2's Owned: 1
Gender: Male
Location: Glenrothes: The Kingdom of Fife
Has thanked: 44 times
Been thanked: 114 times
Contact:

Re: Electric Aerial Makes Noise but Won’t Move

Post by jimi »

:th: Wot he said ^^^^^
Black is not a colour ! .... Its the absence of colour
Image

Topic author
NedPowell
Full Member
Full Member
Posts: 5
Joined: 14/07/22 11:14
Current Model: MK2
Years of MR2 Ownership: 1
MR2's Owned: 1

Re: Electric Aerial Makes Noise but Won’t Move

Post by NedPowell »

Thanks for your replies both. I guess I’ll peruse the auction sites/get in touch with some breakers to see whether anyone has any aerials for sale!
1996 MK2 Rev 3 T-Top N/A - 202 Astral Black
User avatar

TonyleFrog
Full Member
Full Member
Posts: 5428
Joined: 29/07/06 1:00
Current Model: None
Years of MR2 Ownership: 16
MR2's Owned: 6
Real Name: Three guesses!
Gender: Male
Location: Kent
Been thanked: 28 times

Re: Electric Aerial Makes Noise but Won’t Move

Post by TonyleFrog »

jeff wrote: 13/09/23 9:24 for £50 i would go for that option, you could spend time and effort trying to fix your original mast and still be no better off
Agree. I wouldn't go the s/hand route tbh. Buy new, as it's sure to work. Per jimi's link, or this.
https://www.ebay.co.uk/itm/260918252062 ... SwduZac3QN
Which is what I bought when the plastic toothed rack on my Rev3 aerial went belly up.
I preferred the look of the chrome cap and securing nut on my existing unit and simply swapped them over.

As it's not OEM you might need to fabricate a simple bracket to help anchor it in place.
If you're not living life on the edge, you're taking up too much room!

HM wrote: TonyleFrog aka "The Fog Penetrator"
User avatar

jimi
Administrator
Administrator
Posts: 5121
Joined: 17/05/04 1:00
Years of MR2 Ownership: 18
MR2's Owned: 1
Gender: Male
Location: Glenrothes: The Kingdom of Fife
Has thanked: 44 times
Been thanked: 114 times
Contact:

Re: Electric Aerial Makes Noise but Won’t Move

Post by jimi »

Nice find Tony :th:
Black is not a colour ! .... Its the absence of colour
Image
Post Reply

Return to “ICE”